Back
Maintenance

Version updates on instanced

Completed 27 May at 11:59pm CEST.

Sample instance
Completed

Maintenance completed

Posted 27 May at 11:59pm CEST.
Started

All instances will be down due to major version updates

Posted 24 Apr at 12:00am CEST.